This site is in archival mode. A replacement is being developed. In the meantime, please use the PBW2 Forums for community discussions. The replacement software for this site will use a unified account system with PBW2, and any newly created threads will carry over.
Welcome to Spaceempires.net
Login or Register

Search
Modules
· Content
· Downloads
· Forums
· Game Info
· Image Gallery
· Links
· Shipyards
· Topics
· Staff

User Info
· Welcome, Anonymous
Membership:
· New: Astorre
· New Today: 0
· New Yesterday: 0
· Overall: 3155

People Online:
· Visitors: 176
· Members: 0
· Total: 176

  

Spaceempires.net :: Stream Read Errors When Viewing Facilities/Components :: View topic
Forum FAQ :: Search :: Memberlist :: Usergroups :: Profile :: Log in to check your private messages :: Log in


Stream Read Errors When Viewing Facilities/Components

 
Post new topic   Reply to topic    Spaceempires.net Forum Index -> Adamant Mod
View previous topic :: View next topic  
Author Message
bosakm
Space Emperor


Joined: Jan 13, 2007

PostPosted: Wed Aug 01, 2007 3:42 am    Post subject: Stream Read Errors When Viewing Facilities/Components Reply with quote

I get an error when the mod is trying to load the image for Research Center II:

se-iv install dir\pictures\facilities\facil_638.bmp

I believe I installed the ImageMod correctly. In fact I just tried downloading from http://imagemodserver.mine.nu/other/MM/SE4/imagemod/ and installing the v17 facilities zip file again and still get the same error.

BTW, I've installed version 0.16.04 version of Adamant Mod


Back to top
Pax
Space Emperor


Joined: Dec 30, 2005
Location: U.S. Northeast

PostPosted: Wed Aug 01, 2007 3:50 am    Post subject: Reply with quote

Bosakm - try opening it with MSPaint, or whatever other bitmap editting file you prefer, and saving it again. Some of the imagemod files occasionally aren't quite saved in the right format, extension not withstanding.

-- Sean

Like Xbox, Playstation, or Nintendo console games? Rent them online from Gamefly (and help me get free stuff) ...


Back to top
bosakm
Space Emperor


Joined: Jan 13, 2007

PostPosted: Wed Aug 01, 2007 4:26 am    Post subject: Reply with quote

Same problem (disregard previous reply if viewed. Posted it too soon).

I even tried Opening with MSPaint, saving to a different directory and then replacing the .bmp file with the saved copy and still have the same problem.

My next attempt will be to delete the entire mod and re-install.

BTW, I started with Adamant 0.16.00 FQM.exe and have been applying the patches as they've been available.


Back to top
Fyron
Galactic Guru


Joined: Aug 04, 2003
Location: CA, USA

PostPosted: Wed Aug 01, 2007 4:38 pm    Post subject: Reply with quote

This is not a bug in Adamant Mod, but rather SE4 not handling some images in the Image Mod properly.

Adobe Photoshop inserts non-standard garbage into bitmap file headers (though only when saving with the "Windows" format). Most programs are able to cope with this. However, whatever graphics library SE4 uses has trouble with these file headers, sometimes, on some systems, resulting in errors when trying to read the file.

It is fairly easy to resolve the issue. The easiest way to resolve such issues is to resave the images as bitmaps in another program. One option is to use the batch conversion utility of IrfanView (freeware) to convert the bitmaps into bitmaps. You might need to save the output files to a temporary folder first, to ensure that IrfanView actually saves them.


Smarter than your average Texrak.


Back to top
CaptainKwok
Balance Guru


Joined: Aug 04, 2003
Location: Toronto, Canada

PostPosted: Wed Aug 01, 2007 4:47 pm    Post subject: Reply with quote

Related question for Fyron - have you ever run the .bmp conversion on your ImageMod source files?

Space Empires Depot | SE:V Balance Mod


Back to top
bosakm
Space Emperor


Joined: Jan 13, 2007

PostPosted: Thu Aug 02, 2007 1:37 am    Post subject: Reply with quote

CaptainKwok:

No I never ran any bitmap conversion program on any SE-IV files. I never ran across anything in the forums that referenced before. I'll d/l the program that Fryon referenced & give it a try.


Fryon:

Thanks for your help. I'll not update this thread unless I still have problems.

BTW, I new the problem was really with the ImageMod and not Adamant Mod; but I didn't know where else to post to and I only ran into the problem with the Adamant Mod. (Probably because it uses images none of the other mods that I have installed references them). I figured that with all the experience you and the other modders I've seen in these forums, someone would have a solution.

Sorry about 'blaming' your mod.

On an unrelated note: Thanks for your improved ModLauncher. I use it instead of the Matrix one now.


Back to top
CapnKy
Space Emperor


Joined: Jan 01, 2005

PostPosted: Thu Aug 02, 2007 3:35 pm    Post subject: Reply with quote

I believe this is an issue in several of the Galactic Civilizations 1/2 images, of which Adamant makes some use...

Someone should tell whoever maintains the ImageMod Pack (SJ?) to run the facilities set through IrfanView. I don't think any of the other areas suffer from Stream Read Error problems, but you can never be certain.


Unofficial Adamant 0.16.xx Bug Hunter


Back to top
Fomoria
Space Emperor


Joined: Jul 03, 2007

PostPosted: Fri Aug 03, 2007 12:05 am    Post subject: Reply with quote

For those with PSP 8 (and possibly other versions of PSP), the batch process feature without a processing script and "New Type" for save mode will perform the same function as Irfanview.

It saves an additional download if you already have PSP, that's all.

Edit: It was a little iffy as to whether PSP suffered saving issues related to those of PS, hence my post.


Back to top
Display posts from previous:   
Post new topic   Reply to topic    Spaceempires.net Forum Index -> Adamant Mod All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
All logos and trademarks used on this site, all comments and stories posted for reading, all files hosted for download,
and all art work hosted for viewing are property of their respective owners; all the rest copyright 2003-2010 Nolan Kelly.
Syndicate news: SpaceEmpires.net News RSS Feed - Syndicate forums: SpaceEmpires.net Forums RSS Feed
Page Generation: 0.24 Seconds